漏洞追踪:如何检查并修复GHOST(幽灵)漏洞

编号CVE-2015-0235的GHOST(幽灵)漏洞是Qualys研究员发现的一个Linux服务上非常严重的安全漏洞,可以被利用来远程代码执行及本地权限提升。

20150320104007771

漏洞简要描述

该漏洞存在于 glic 库中的__nss_hostname_digits_dots() 函数,在nss/getXXbyYY.c这个文件中,gethostbyname()会使用这个功能。另外,这个漏洞本地远程都可以利用,要利用此漏洞,攻击者需要构造一个特定的 hostname 数据条给linux 上开放的服务,如果服务不对数据做安全处理,就会引发一个任意代码执行漏洞。

下面列出了几个受影响的服务:

procmail

Exim

pppd

clockdiff

你也可以用下面命令来查看你的 server 上有哪些服务依赖 glibc:

lsof | grep libc | awk ‘{print $1}’ | sort | uni

下面是各个系统的升级方法:

Centos/RHEL/Fedora 5,6,7

yum update glibc

sudo restart

ubuntu

sudo apt-get update

sudo apt-get dist-upgrade

sudo restart

相关链接:

CVE-2015-0235 – How to secure against Glibc Ghost Vulnerability

http://www.openwall.com/lists/oss-security/2015/01/27/9

译者注:

用镜像源升级之后,需要重启受影响的进程,最好是重启系统;

Android 系统上面使用的是 Google 专门为 Android 开发的 C/C++ 库:Bionic,该库不同于 glibc;

文章来源:Freebuf黑客与极客(FreeBuf.COM)

 

发表评论

邮箱地址不会被公开。 必填项已用*标注