BT5R3蛋疼的metasploit升级

  刚装了BT5R3,急着想把metasploit升级,原版本是4.5.0,试了网上的各种方法,终于试到了个能成功的,再次记录一下。

  系统环境:BT5 R3

  1、apt-get update

  2、apt-get install metasploit

  3、修改文件:/opt/metasploit/ruby/lib/ruby/1.9.1/i686-linux/rbconfig.rb

  CONFIG["LIBRUBYARG_STATIC"] = “-Wl,-R -Wl,$(libdir) -L$(libdir) -l$(RUBY_SO_NAME)-static”

  改为:CONFIG["LIBRUBYARG_STATIC"] = “-Wl,-R -Wl,$(libdir) -L$(libdir) ”

  (就是去掉-l$(RUBY_SO_NAME)-static)

  4、切换至/opt/metasploit/msf3然后运行/opt/metasploit/ruby/bin/bundle install

  5、msfupdate

  终于OK了。

 

发表评论

邮箱地址不会被公开。 必填项已用*标注